Курс Data Communication: Дата тууралуу жазабыз

Course Content

Total learning: 17 lessons Time: 10 weeks

Дата маалыматарды анализдөөнүн негизги жолдору, 1-бөлүк

Сабактын кыскача мазмуну: Бул сабакта сиз маалыматты анализдөөнүн негизги ыкмаларын үйрөнөсүз.

Биздин колубузда 2012-жылдан 2016-жылга чейинки инфекциялык жана паразиттик оорулардын таблицасы турат. Таблица адам сыяктуу эле: биз ага суроо берип, жооп алсак болот. Мында Excel формулалары жардамга келет. Фильтрдин жардамында биз төмөндөгү суроолорго буга чейин жооп алдык:

  • 2012-жылы адамдардын көпчүлүгү кайсы инфекциялык/паразитардык дартка кабылган? А 2016-жылычы?
  • Кайсы инфекциялык/паразитардык оорулар менен адамдар азыраак жабыркаган?

Тапшырма: Ушул таблицага дагы бир нече суроолорду ойлоп тапкыла.

Биз ойлоп тапкан бир нече суроолор төмөндө:

  • Беш жылда ар бир ооруга канча адам чалдыккан?
  • Кайсы оору эң көп катталган?
  • Бир жылда тигил же бул ооруга орточо канча адам чалдыгат?
  • Акыркы жылы бул ооруга адаттагыдан көп адам кабылганбы же азбы?

Эми бизде суроолор пайда болгондон кийин алардын айрымдарына жооп берүүгө аракет кылалы. Бул үчүн биз Excel`дин формулаларын колдонобуз. Алар таблицадагы уячалардын (ячейка) ичинде эсептөөлөрдү жүргүзүүгө жардам берет:

  • Excel`дин бардык формулалары барабар белгисинен башталат.
  • Excel`деги негизги эсептөөлөрдү негизги математикалык белгилер менен жасаса болот: + сумма үчүн, – айырма үчүн, / бөлүү үчүн жана * көбөйтүү үчүн.

Сумманы СУММ функциясын колдонуу менен эсептейбиз.

Мисалы, 2015- жана 2016-жылды кошо алганда ич келте (брюшной тиф) менен паратифти канча адам жуктуруп алганын эсептеш үчүн бош уячага туруп, формуланы жазышыбыз керек:

= Е2+F2

Е2 жана F2`ни  өзүбүз жазсак да болот, же ошол уячаларга бир жолу бассак болот.  Enter`ди, басыңыз, жыйынтык чыгат: 81.

Беш жылда ич келте (брюшной тиф) жана паратифке кабылган адамдардын жалпы санын кантип  эсептесе болот? Ар уячаны өз өзүнчө жазып чыкса болот, бирок бул өтө узак. Бизде 5 эмес, андан бир топ көп жыл бар деп элестетиңиз. Бул үчүн Экселде функциялар бар, алардын бирин азыр колдонуп көрөлү.

Функциялар – бул көрсөтүлгөн блоктор менен математикалык эсептөөлөрдү жүргүзүүгө шарт түзгөн командалар. Биздин учурда сумма функциясы ич келте дартынын беш жылдагы жалпы санын эсептөөгө жардам берет.

Сумманы эсептеш үчүн “СУММ”  (англисче ферсиясында SUM) функциясы бар. Функциялардын көпчүлүгү аббревиатуралар менен көрсөтүлгөн.

Уячага жазыңыз: =СУММ же =SUM

Сиз функцияны жазып баштарыңыз менен ал  төмөн жакта чыккан тизмеден көрүнөт. Аны басыңыз.

Эми кашаанын ичине суммасын эсептеш керек болгон уячалардын диапазонун жазыңыз. Биринчи уяча – B2`ге басыңыз ( 2012-жылдагы оорулар) жана чычканчаны кое бербей туруп,  F2`ге (2016-жылдагы оорулар) чейин алып барыңыз. Сизде формула пайда болушу керек.

=СУММ(B2:F2) же  =SUM(B2:F2)

Enter`ди басыңыз, жыйынтык чыгат:  271.  2012-16-жылдары Кыргызстанда 271 адам  ич келте менен паратифке кабылган.

Биздин тилкени “2012-2016 суммасы” деп атап коелу.

Ар бир оору боюнча ушундай жалпы эсепти кантип чыгарса болот? Кайрадан формуланы киргизсе болот, же тилкеден ылдый карай формуланы көчүрүп алса болот. Бул үчүн G2 уячасынын ылдыйкы оң бурчуна туруңуз. Чычканчанын курсору кара ичке крест белгисине айланып калат. Эки жолу басыңыз, сизди тилке талбицанын аягына чейин толуп калат.

Эми биз биринчи сапка фильтр коюп, G тилкесиндеги маалыматтарды азынан көбүнө карай иргеп алсак болот. Биринчи суроого жооп алдык: акыркы беш жылдагы эң көп катталга инфекциялык жана паразитардык  беш оору – дем алуу жолдорунун инфекциясы, ичеги-карын  инфекциялары, гепатит, гастроэнтериттер жана кызамык.

Беш жылда ар бир ооруга канча адам кабылган? Кайсы ооруга эң көп адам чалдыккан?  Беш жылда дээрлик миллион  – 926 677  адам тамак жана өпкөнүн инфекцияларына кабылган. Бирок бул чындыкпы?

Чынында биздин колубузда оорунун катталган учурлары бар таблица турат. Эгер бир адам жыл сайын ооруса, ал жылда бул таблицага кошула берет. Буга кошо эгер ал бир жылда эки жолу ооруса, анда ал ошол жылда статистикага эки ирет кошулат. Же тескерисинче, кимдир бирөө үйдө дарыланып, дарыгерге барбаса, анда ал статистикада жок.

Ошентсе да биз дем алуунун жогорку жолдорунун инфекциясы – таблицада эң көп кездешкен оору экенин көрүп турабыз. Ашказан инфекцияларына чанда кабылышат.

 СРЗНАЧ функциясын колдонобуз.

Ар бир оору боюнча бир жылда орточо канча учур катталат? Бул суроого жооп тапсак, биз оорулар боюнча жалпы абалды түшүнөбүз: анык бир жылга алынган маалыматын ордуна биз негизги тенденцияларды көрөбүз. Бул үчүн биз орточо маанини эсептешибиз керек.

Муну өзүнчө тилкеде жасайлы. Аны “2012-2016 орточо” деп атаңыз. Н2 уячасына =СР формуласын жазып баштаныз, төмөндө пайда болгон тизмеден СРЗНАЧ (AVERAGE)  тандаңыз.

Сизге сумманы эсептегендегидей эле диапазон керек. Сиздин формула мындай көрүнүштө болот:

=СРЗНАЧ(B2:F2) же =AVERAGE(B2:F2).

Enter басыңыз, жыйынтык чыгат:  орточо алганда жыл сайын дем алуу жолдорунун инфекциясынан 185 миң учур катталат. H2 уячасынан ылдый карай формуланы көчүрүңүз.

Биз бул маанини кантип таптык? СРЗНАЧ формуласы сумманы уячалардын санына бөлүп коет. Муну өзүңүз текшерип көрсөңүз болот: “сумма” тилкесиндеги бардык жылдардагы дем алуу органдарынын инфекцияларынын санын 5ке бөлүңүз.

Көңүл буруңуз, сиздин маанилерде үтүрдөн кийин да сандар бар. Анткени бөлө келгенде дайыма эле бүтүн сан чыга бербейт. Бирок сиз маанилерди тегеректесеңиз болот.  Аларды белгилеп, «уменьшить разрядность» баскычын басып, үтүрдөн кийинки сандарды кыскартыңыз.

Эми сиз, мисалы, 2016-жылдын көрсөткүчтөрүн орток көрсөткүч менен салыштыра аласыз. Андан сиз акыркы жылдагы көрсөткүч чоң же кичине экенин билесиз. Алсак, 2016-жылы жогорку дем алуу жолдорунун инфекциясынан 261 366 учур катталган. Акыркы беш жылды алсак, жыл сайын орто эсепте 85 миң учур болгон. Бул эмнеден кабар берет?

Эскертме: ушул сабактын башындагы суроолорго жооп берүү үчүн эми сизде бардык маалымат бар.

 

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *